ImpressCMS, SSL and Cloudflare Free

Posted by fiammybe on 1547638420
<p>I setup my ImpressCMS site using a <a href="https://letsencrypt.org/">Let's Encrypt SSL certificate</a>. Everything works fine, nothing specific to configure other than putting 'https' in your root url. The site was running a bit sluggish, due to the server being on the other end of the world, so I decided to activate the free Cloudflare option my hosting company offered.</p>

<p>After that, once Cloudflare was up and running, my site was unreachable due to 'the site redirecting in an incorrect way'. Because the site has been working without issue before, I figured it was the cloudflare setup that needed adapting.</p>

<p>I found <a href="https://support.cloudflare.com/hc/en-us/articles/200170536-How-do-I-redirect-all-visitors-to-HTTPS-SSL-">this article on the cloudflare support site</a> that explains what was happening : my site was SSL-only, but the cloudflare default setting is for 'Flexible SSL'. The Flexible SSL option acts as a SSL proxy between your users and your site, and can be a good option if you don't have the opportunity to run your site with an SSL certificate, but you want to expose an SSL address to the world. Cloudflare then exposes a HTTPS address to the outside world, but communicates with your servers without it.</p>

<p>Changing the option from 'Flexible SSL' to 'Full SSL' immediately fixed the issue for me. Site response times have improved considerably since then.</p><!-- input filtered -->

This Post was from: https://www.impresscms.org/iforum/viewtopic.php?topic_id=5848&post_id=50576