Subject:*
Name/Email:*
Message Icon:*
Message:*
url email imgsrc image php hide code quote
SAMPLE
alignleft aligncenter alignright bold italic underline linethrough   


 [more...]
Options:*
 

 

 
View requirements*
Reply No requirement
Confirmation Code*
  The code is case-insensitive  Click the image for a new code. | Maximum attempts: 8
   
Re: A project I've been putting off - ICMS 1.2.x to 1.3.x

by fiammybe on 2020/6/21 0:06:15

iForum 2 is not compatible with PHP7, on top of that. I'm not sure if it is a worthwile time investment to try to patch iForum 2, given that it uses the Art framework instead of IPF. Potentially, many issues will also be in Art.

I want to re-do iForum in IPF, but that would be iForum 3, and would be PHP7 compatible


Re: A project I've been putting off - ICMS 1.2.x to 1.3.x

by skenow on 2020/6/20 9:28:53

More results - iForum 1.0 Final also requires ImpressCMS 1.3+, while iForum 1.0 RC does not.


Re: A project I've been putting off - ICMS 1.2.x to 1.3.x

by fiammybe on 2019/9/23 0:33:00

thanks for the update, I have updated the information on the github page : https://github.com/iForumModule/iforum/blob/master/README.md

One of these days I should test iForum thoroughly on PHP7 and release the 2.0 final


Re: A project I've been putting off - ICMS 1.2.x to 1.3.x

by skenow on 2019/9/22 7:49:53

Ran some tests this morning - iForum 2.0 requires ImpressCMS 1.3+ and not 1.2+ as the readme states. I'll have to do this in stages


Re: A project I've been putting off - ICMS 1.2.x to 1.3.x

by fiammybe on 2019/9/22 2:07:35

I'm thinking of updating the imBuilding templates to make them compatible with 1.4. While doing that, adding a skeleton to support fine-grained permissions might be a worthwile improvement.