Fork me on GitHub

carousel no longer working after upgrade to ImpressCMS 1.3.11

Hi,

after we upgraded the ImpressCMS site (this one) to the latest version using Softaculous, we noticed after a short while that the carousel on the front page wasn't working anymore.

looking at the HTML sourcecode, the content was still there, but for some reason it wasn't showing on the screen anymore.

We noticed an error message in the browser logs telling us that the version of jQuery was too recent. As a quick fix, I downgraded the jQuery included in ImpressCMS to the one we bundled previously (1.9.1). Further investigation by @skenow revealed that it's our theme that is slightly too old and not using the latest version of Bootstrap 3. Bootstrap 3.3.7 supports jQuery higher than 3.0.

We'll upgrade our bootstrap and possibly our carousel version in the near future, but I just wanted to let you know in case you run into the same problem. It's not a core issue, it is most likely related to the bootstrap version in your theme.

Topic


Re: Language flags do not appear correctly

I had a look at how the block works that displays the language flags, and it's quite basic and straightforward. I'll look into improving that in the future.

Topic


Re: Language flags do not appear correctly

Looks like we need to use a little trim function there

Steve Twitter: @skenow Facebook: Steve Kenow



Re: Language flags do not appear correctly

I found out that I needed to remove the spaces between the definitions of the languages.

Quote:

Instead of 'nl, fr, en', I needed to have 'nl,fr,en'. That made it work.



Simple, by you need to think about it



Language flags do not appear correctly

Hi, I have several languages on my site (I live in Belgium, at least 3 languages are the norm here).
When I look in the backend (with iTheme), my first language is appearing ok (flag and all), but the other languages don't have their flags and only show the label I defined for them.

Any idea what could be the reason?



Re: I can not change any more settings - to upgrade to version 1.3.9

  • 2016/8/16 3:14:33

Hi @skenow,

thank you for your reply. Ok, I'll then leave once without "pdo".

PHP 5.6 should be sufficient once for my domain.

Since I have several CMS installations in subdirectories, I can not work with PHP 7.0.

What will be in the future so that we will see :)



Re: I can not change any more settings - to upgrade to version 1.3.9

I'm glad you figured this out.

PDO is enabled, by default, on PHP 5.1+. You would need to look at your server to determine if it is enabled, though. If it is not available and you have set up ImpressCMS to use PDO, the debugger should show a message that PDO is not available. (the exact message is "PDO extension not available.")

While we have found the core to work fine under PDO, not all modules have been made compatibile with PDO.

As for PHP 7, I have yet to run complete tests on it. The MySQL extension is completely out, so you'd have to run everything under PDO.

Steve Twitter: @skenow Facebook: Steve Kenow



Re: I can not change any more settings - to upgrade to version 1.3.9

  • 2016/8/15 11:16:57

Hi,

I found the mistake :)

It's so that I could not use "pdo" by MySQL. But otherwise, I thought that it is up to PHP 5.5. Then PHP 5.6 have enabled and removed just "pdo" in mainfile.php File.

Ly8gRGF0YWJhc2UgLy8gQ2hvb3NlIHRoZSBkYXRhYmFzZSB0byBiZSB1c2VkIGRlZmluZSggJ1hPT1BTX0RCX1RZUEUnLCAncGRvLm15c3FsJyApOw==

Then the updating of the system module worked and I was able to change other settings well.

Very strange why "pdo" does not work for me. Whether it's a bug ??

Another question?! Can I work in ImpressCMS with PHP 7.0.8? That would be interesting to know.

Thanks in advance.



Re: I can not change any more settings - to upgrade to version 1.3.9

Hi Alex,

I don't know if you can give more details about the steps you took with the update? As far as I know, upgrading from 1.3.8 to 1.3.9 should be as simple as logging in to the admin panel, overwriting the files on the server, and updating the system module.

Did you do an upgrade from 1.3.8, I presume you did. What version of PHP and MySQL are you using?

When you say that you cannot change settings in the backend, do you get an error message, or any other strange behaviour?



I can not change any more settings - to upgrade to version 1.3.9

  • 2016/8/10 19:02:25

Hello Developers,

only today I've noticed is that a new Impress CMS was version 1.3.9 released. Upgrading was easy and I do it mostly with SSH.

But now after upgrade I can change any settings in the backend. It simply has not happened.

I wanted to ask the Developers Dashboard to inactive and activate new theme. But that does not work.

How can I solve the problem?

Thanks in advance, Alex



Re: Podcast-module: protector-bug

What is the mimetype of the image, and can you tell us the filename? Podcast automatically authorises itself to use .png, .gif. and .jpg mimetypes on install.

I think you can allow double dots in file names by turning off the option 'protect from directory traversals' in Protector, but generally it is best to keep filenames to simple alphanumeric characters. Don't use slashes, double dots, or quotes, anything that looks like it might be a null byte etc will get rejected.



Re: Podcast-module: protector-bug

  • 2015/12/9 20:49:38
  • Kang

This message my friend:

Protector detects attacking actions

Never happen before



Re: Podcast-module: protector-bug

Is this the same issue you reported in Image Manager - Invalid File Type?

Steve Twitter: @skenow Facebook: Steve Kenow



Re: Podcast-module: protector-bug

Hi, can you give the specific error message please? There should be a clue in there.



Re: Podcast-module: protector-bug

  • 2015/12/9 8:13:25
  • Kang

Got same problem.
Without multiple dots and correct MIME type.
Please help.

Regards form Malaysia


Re: $icms_langcode is always english

Well spotted. I had everything configured on the 'multilingual' page, but forgot about the setting in the general settings. I changed that and it brings me the language in the smarty template. This breaks the backend, so I guess there's some error in my translation package. Another issue, but this one is solved.



Re: $icms_langcode is always english

What is the default language in Preferences > General Settings? And what is the setting in Preferences > Multilanguage "Autoselect the language depending the browser configuration"?

Steve Twitter: @skenow Facebook: Steve Kenow



$icms_langcode is always english

Hi, I've setup a site for the Belgian ImpressCMS community (http://www.impresscms.be), with 2 languages : nl_BE and fr_BE. The site does not include english. I checked, and there are only the dutch and french languages codes on the /modules/system/admin.php?fct=preferences&op=show&confcat_id=8 page (multilanguage)

I created a new theme, and put $icms_langcode in the header to indicate the language. When I go to my page, I see the content in Dutch (nl_BE), but the language is still mentioned as 'en' in the header.

When I define the language code explicitly in the URL, the language indicator is ok.

How do I make ImpressCMS choose the right language as a default, any idea?



Re: error causing blank page n article.php

Hi Gerry,

could you send me the version of the module with the changes? I'd like to include them in the next version of the module.

Thanks!



Re: error causing blank page n article.php

I'm currently completing the detailed part, but you can have a good idea here : Moving Server on Wiki




 Top