Re: Module versions in Addons

  • 2008/10/13 6:11:20
  • Will

We need to do something about the search function - it doesn't work at all.

Topic


Re: Module versions in Addons

Thanks!

I would suggest to do something about the module's title bar (bold, slightly bigger font).
Now the footer (Review Resource, Rate Resource, Report Broken) is the eyecatcher.

McDonalds Store
Topic


Re: Module versions in Addons

I'm going to be working on this site in the next few days - so any issues anyone can report are appreciated

Also - anyone able to give a hand is appreciated

Topic


Module versions in Addons

I was just browsing the Addons by letter and noticed that for most modules the version number is not displayed.
See here for an example. Only for Web Show and WF-Resources the version number is displayed.


Shouldn't the version number and maybe the release status also be visible in these pages?

Can be useful I think when having a module with different version numbers listed.


There's also a template or CSS issue I noticed at the top and bottom. The grey background extends here too far to the left.

McDonalds Store
Topic


Re: Modules adjusted to work within Impresscms

Yes, I believe these will be added.

Topic


Modules adjusted to work within Impresscms

  • 2008/10/1 15:11:50
  • Shine

Some original for xoops 2.3 modules have to be customised for work within impress.
I see some modules and code adjustments flying by.......

Will these adjusted modules (which than will function within impresscms) also be added within the impresscms addons section?
Would be nice and a great service, otherwise we all need to adjust the modules ourselves and/or will have the same questions over and over again. And not all users feel like doing (or are able to do) this.

Grtz., Shine

Environment:
PHP Version 5.2.4
SQL: 5.0.77
Zend: v2.2.0
Apache: 1.3.39
Topic


Re: Mastop download link

That's solved the problem I had and one I had not yet encoutered.

Thanks guys

Topic


Topic


Re: Mastop download link

Solve your problem ?

Giba
Topic


Re: Mastop download link

Quote:

...there seems to be a conflict on the admin side between the menu produced by iCMS and another, I think produced by the module, at the same time in the same place, on the admin side of the module.



There's a fix here in this forum for this problem, but I can't find it at this moment.

If you can't understand what I'm saying, you're not geek enough
ISegura.es
Topic


Mastop download link

The link for the mastop publish download takes the user to the wrong page.
Also, having just installed this module, there seems to be a conflict on the admin side between the menu produced by iCMS and another, I think produced by the module, at the same time in the same place, on the admin side of the module.

Topic


Re: Errors while installing modules

I think that will have problems with CDM and Xgen if using with php5. The impresscms 1.1 version only allows support for php5 and you should check in the system developer Aktinson on the updates. I would be very happy if this tool kit for generating modules one day work in perfect impresscms. I performed tests in the past and did not work even with the correction of databases. So I think it will not work right for you.

In the site http://xoobs.net/ is exelent font for support and aktison is good person.

[pt-br]
Eu penso que irá ter problemas com CDM e Xgen se estiver usando com php5. A versão impresscms 1.1 só permite suporte para o php5 e você deverá verificar no siste do desenvolvedor Aktinson sobre as atualizações. Eu ficaria muito feliz se este tool kit de geração de módulos um dia trabalhar perfeito em impresscms. Eu realizei testes no passado e não trabalhou mesmo com as correções de bancos de dados. Desta forma eu penso que não irá trabalhar correto para você.

[/pt-br]

Giba
Topic


Re: Errors while installing modules

davidl2,

Thanks for the pointer.

Chris

Topic


Re: Errors while installing modules

The site for the modules author is: http://xoobs.net - which may be useful as well.

Topic


Re: Errors while installing modules

GibaPhp,

I greatly appreciate your efforts. Please do not apologize for the translated English. I will make sure that I include the needed information so that others can help when I ask for such.

I have not found a reference to a library. I read the description of the XBS Generator Module. (link: http://addons.impresscms.org/modules/wfdownloads/singlefile.php?lid=35 ) and also did a search in Google for the same. I found reference at xoops.org forum / article suggesting I should look at the install text located in the docs folder of the module. DUH!

There I found the following instructions,

1/ Install XBS CDM (Code Data Management) module first. You can find this module at the same place as you found this one.

2/ Install this module (XBS ModGen) as per normal Xoops module installation

It took me a bit of time to locate the support CDM module. (link: http://www.xoops.org/modules/repository/singlefile.php?cid=19&lid=1658 )

Thanks for the lead....

Sincerely, Chris

Topic


Re: Errors while installing modules

KShop,

There was one additional error related to MySQL 5.

The field comments in the table declaration of CREATE TABLE `kshop_orders_status` needs the default removed.

These are located within the 'mysql.sql' file of the KShop module and in the folder sql.


xosCommerce

Corrected within within the 'mysql.sql' file of the xosCommerce module and in the folder sql.

CREATE TABLE osc_customers_info (
No changes needed to the create table

The insert of the new record should read as below.
INSERT INTO osc_customers_info VALUES('1', now(), '0', now(), now(), '0');

It works but some other syntax is causing a server error. Will report back on that after I track it down.


XBS Module Generator

Can't create table '.\adipcms\ipcms_xbs_modgen_object.frm' (errno: 150)

Unable to install xbs_modgen. Error(s):

I agree; bad table name or truncated code. I think I'll wait for this one. Perhaps I'll tackle it down the road if it doesn't have a fix in a couple of weeks.


XPlainCart

The file to make the changes in is http://webroot/modules/xplaincart/plaincart.sql

CREATE TABLE `plain_category` (
`cat_id` int(10) unsigned NOT NULL auto_increment,
`cat_parent_id` int(11) NOT NULL default '0',
`cat_name` varchar(50) NOT NULL default '',
`cat_title` varchar(255) NOT NULL default '',
`cat_description` text NOT NULL, // << removed default value
`cat_image` varchar(255) NOT NULL default '',
PRIMARY KEY (`cat_id`),
KEY `cat_parent_id` (`cat_parent_id`),
KEY `cat_name` (`cat_name`)
) TYPE=MyISAM AUTO_INCREMENT=18 ;

The change you gave worked like a charm!

Thanks for the kick start. Will be able to locate and trouble shoot these types of issues better in the future.

Chris

Topic


Re: Errors while installing modules

Yes I am using MySQL 5,,
All of the modules were downloaded from the impresscms site as modules / addons.
Thanks for the details...

Topic


Re: Errors while installing modules

All those errors do indicate a problem with MySQL syntax, some are more likely to occur when you are using MySQL 5 because the syntax is stricter. Some installations of MySQL are also configured to use strict mode, which will result in more errors and problems for loosely coded sql.

Most are easy to correct, look at the sql folder of the module in question and edit mysql.sql. then look for the problem identified and make the correction.

Quote:


Field 'deff' doesn't have a default value

Unable to install kshop. Error(s):



CREATE TABLE `kshop_status` (
`sid` int(5) unsigned NOT NULL auto_increment,
`status` varchar(20) NOT NULL,
`deff` tinyint(4) NOT NULL,
PRIMARY KEY (`sid`),
KEY `status` (`status`)
) TYPE=MyISAM;


Since the definition says the field cannot be null, you must add a default value, like

`deff` tinyint(4) NOT NULL default 0,


Quote:


Installing xosCommerce

Incorrect datetime value: '' for column 'customers_info_date_of_last_logon' at row 1

Unable to install osC. Error(s):



The insert statement tries to insert an string to a numeric (datetime) field


CREATE TABLE osc_customers_info (
customers_info_id int NOT NULL,
customers_info_date_of_last_logon datetime,
customers_info_number_of_logons int(5),
customers_info_date_account_created datetime,
customers_info_date_account_last_modified datetime,
global_product_notifications int(1) DEFAULT '0',
PRIMARY KEY (customers_info_id)
);

INSERT INTO osc_customers_info VALUES('1', '', '0', now(), '', '0');


There are 2 fields that will have problems - the 2nd and 4th. Either


INSERT INTO osc_customers_info VALUES('1', , '0', now(), , '0');

or

INSERT INTO osc_customers_info VALUES('1', 0, '0', now(), 0, '0');

should work.

Quote:


Installing XBS Module Generator

Can't create table '.\adipcms\ipcms_xbs_modgen_object.frm' (errno: 150)

Unable to install xbs_modgen. Error(s):



Definitely not a valid table name. Something wrong in the code that generates that.

Quote:


Installing XPlainCart

BLOB/TEXT column 'cat_description' can't have a default value

Unable to install xplaincart. Error(s):



In this case, remove the default value and the word 'default' from the field definition.


CREATE TABLE `plain_category` (
`cat_id` int(10) unsigned NOT NULL auto_increment,
`cat_parent_id` int(11) NOT NULL default '0',
`cat_name` varchar(50) NOT NULL default '',
`cat_title` varchar(255) NOT NULL default '',
`cat_description` text NOT NULL default '',
`cat_image` varchar(255) NOT NULL default '',
PRIMARY KEY (`cat_id`),
KEY `cat_parent_id` (`cat_parent_id`),
KEY `cat_name` (`cat_name`)
) TYPE=MyISAM AUTO_INCREMENT=18 ;


becomes


CREATE TABLE `plain_category` (
`cat_id` int(10) unsigned NOT NULL auto_increment,
`cat_parent_id` int(11) NOT NULL default '0',
`cat_name` varchar(50) NOT NULL default '',
`cat_title` varchar(255) NOT NULL default '',
`cat_description` text NOT NULL,
`cat_image` varchar(255) NOT NULL default '',
PRIMARY KEY (`cat_id`),
KEY `cat_parent_id` (`cat_parent_id`),
KEY `cat_name` (`cat_name`)
) TYPE=MyISAM AUTO_INCREMENT=18 ;

Steve Twitter: @skenow Facebook: Steve Kenow

Topic


Re: Errors while installing modules

Most of the errors identified seem to be related to the database. Which version of MySql you using?
Regarding the module XBS Generator Module, I think we need some form of a library module before.
Whenever possible, pass the largest number of details on its server, database, version of php, is used to GD among other things. Excuse my poor English, using translators to send the message.

Please exact link from which dropped each module. Most can not use this module now, but if you provide the address this will help those who want to help Downloading this module to do the testing necessary to help.


[pt-br]
A maior parte dos erros apontados me parece ser relacionado ao banco de dados. Qual a versão do MySql você está usando ?
Com relação ao módulo XBS Module Generator, em penso que é necessário alguma biblioteca em forma de módulo antes.
Sempre que puder, passe o maior número de detalhes sobre o seu servidor, banco de dados, versão do php, se utiliza a GD entre outras coisas. Desculpe meu inglês ruim, utilizando tradutor para enviar a mensagem.

Por favor, link exato de onde baixou cada módulo. A maioria pode não usar este módulo atualmente, mas se você fornecer o endereço isto ajudará quem deseja ajudar baixando este módulo para fazer o teste necessário para lhe ajudar.

[/pt-br]

Giba
Topic


Errors while installing modules

Not a critical issue but I had errors while installing 4 of the modules located in the addons section of the impresscms site. They look like simple errors. If anyone has the answers for any of them it could ease the time ahead of me.

This is more just a FYI. Here they each are listed with their respective error message.

_______________________________
Installing Kshop

Field 'deff' doesn't have a default value

Unable to install kshop. Error(s):

_______________________________
Installing xosCommerce

Incorrect datetime value: '' for column 'customers_info_date_of_last_logon' at row 1

Unable to install osC. Error(s):

_______________________________
Installing XBS Module Generator

Can't create table '.\adipcms\ipcms_xbs_modgen_object.frm' (errno: 150)

Unable to install xbs_modgen. Error(s):

_______________________________
Installing XPlainCart

BLOB/TEXT column 'cat_description' can't have a default value

Unable to install xplaincart. Error(s):


Thanks,
Chris

Topic



 Top