Reply New Topic
2010/9/26 20:13:36
#1
Offline
Home away from home

New Protector 3.50 feature - enable manipulation checking

Protector 3.50 (beta) has a new feature that can be useful, but frustrating if you are accustomed to working directly on your files through ssh or even ftp. Or, even if you want to upgrade your sites through a normal process.

If you enable the 'manipulation checking' feature, any change to any file within your installation will result in a blank page with the message "Protector detects site manipulation". If you happen to change a file, as I just did (changed my .htaccess file) while this option is activated, you will shut down your site and make it inaccessible until you disable the feature in your database.

If you run into this, you'll need to connect to your database, (I used phpMyAdmin), find the module ID for Protector (in prefix_modules), then filter the config table for items for the Protector module. You will be looking for the config_name of 'enable_manip_check' and want to set it to '0'. Then you will be able to access your site again.

This is a very good thing to have, but there needs to be a better way to upgrade your sites, or control the behavior. I'm not sure how GiJoe intends to handle upgrades and recovering sites when the changes are made, but it does need some improvement.

_________________

Steve Twitter: @skenow Facebook: Steve Kenow


Reply New Topic extras
 Previous Topic   Next Topic
You can view topic.
You can start a new topic.
You can reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You can post without approval.