Reply New Topic
2016/3/16 20:19:02
#1
Offline
Home away from home

New install V1.3.9

I just tried to install ICMS 1.3.9 for a new site, I get the following error on step one of the installer:

Quote:

PHP 5.6.0 minimum is required for ImpressCMS to function properly - your installation cannot continue. Please work with your hosting provider to upgrade your environment to a version of PHP that is newer than 5.2.0 (5.2.8 + is recommended) before attempting to install again.



I had PHP 5.4.x on the server, so I recompiled Apache with version 5.5.33 (the latest on offer in WHM) and I still get the same error. Do we really need 5.6?

Edit: Nevermind, I clicked on the help text thing and something got reset and suddenly it recognised 5.5.33, so it's ok.


2016/3/18 6:00:55
#2
Offline
Webmaster

Re: New install V1.3.9

I upgraded that requirement as a sort of security help : PHP 5.6 is the only supported version of PHP 5.x at the moment. Supporting very old versions of PHP is not a good idea security-wise, so I bumped the version requirement to 5.5.

Having said that, I'll need to update the translation variable so that it talks about the correct version of PHP (we're way beyond PHP 5.2+ already).

_________________

Me on Ohloh


Reply New Topic extras
 Previous Topic   Next Topic
You can view topic.
You can start a new topic.
You can reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You can post without approval.