Reply New Topic
2020/10/21 4:59:22
#1
Offline
Just popping in

Error while installing

Hi ! I try to install ImpressCMS 2.0.0 Alpha but I can't run it.  I even try to directly indicate the username,password on Database provider however it just remove the error message and the functionality still can't be use.

php version : PHP 7.4.11

OS : Windows

 

(5th time installation)

 

- clone the repo https://github.com/ImpressCMS/impresscms.git

- run composer install 

- create a .env file (empty file)

- create database named impresscms

- go to /htdocs where it redirect to installation page

- setup database connection (default username and password on xampp) and I also select PDO Mysql

- I add the database name (impresscms) and change the prefix to empty

- setup account

- insert data to database (I get this message : All done. Took 5.5023s)

- install module (Message : Module System updated successfully.)

 

Now it seems the installation complete I go to impresscms/htdocs and it render the error message

 

Clicking multiple times a functionality return this (check image)

Now I solve this via modifying the code (check image)

 

After doing that the error for mysql will not appear anymore but still I can't use the login and the not found message still here..

 

Regards :)


Attach file:


zip errors.zip Size: 200.53 KB; Hits: 17


2020/10/21 6:06:49
#2
Offline
Webmaster

Re: Error while installing

Hi, I see you are trying to connect to the database at 127.0.0.1, and the mysql server is on 'localhost'. I know those are equivalent in practice, but I've had issues before with MySQL that it treats them as 2 different things (in fact they are not the same). can you change 127.0.0.1 -> localhost in your .env file and let me know if that solves the problem?


_________________

Me on Ohloh


2020/10/21 16:37:05
#3
Offline
Just popping in

Re: Error while installing

Hi ! I try it for this time I remove the modification on the code but still it render the error message, If I try to apply again the modification the error message will disappear but still I can't use it..


Attach file:



png  error_3.png (98.68 KB)
3342__94125f90c621545cf.png 1907X930 px


2020/10/22 15:24:50
#4
Offline
Webmaster

Re: Error while installing

Hi, I was able to verify on both PHP 7.3 and PHP 7.4, both with and without a database prefix. It's a bug I created an issue on github.


_________________

Me on Ohloh


2020/11/10 1:10:38
#5
Offline
Webmaster

Re: Error while installing

There is a possible fix for this, could you test it out on your setup as well? I'll check it on mine before approving the Pull Request, but 2 checks is better than 1

https://github.com/ImpressCMS/impresscms/pull/797 


_________________

Me on Ohloh


2020/11/11 14:37:58
#6
Offline
Webmaster

Re: Error while installing

Hi, I checked on multiple instances and the problem is now gone. The Pull Request is now integrated in the master branch. I plan on doing a new alpha by the end of the week.


_________________

Me on Ohloh


2020/11/14 16:19:36
#7
Offline
Just popping in

Re: Error while installing

Apologize for late reply, I will test this now and I will update you



2020/11/14 16:36:55
#8
Offline
Just popping in

Re: Error while installing

I can login now and the error before is already fix. 



2020/11/14 18:58:38
#9
Offline
Webmaster

Re: Error while installing

Great, thanks for confirming that the issue was fixed on your side as well. No problem with slow replies, normal life has its necessities too

I can not even spend a fraction of the time I would like to on ImpressCMS, I sympathize.


_________________

Me on Ohloh


Reply New Topic extras
 Previous Topic   Next Topic
You can view topic.
You can start a new topic.
You can reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You can post without approval.