Fork me on GitHub
  • Posted by fiammybe
  • Posted on 19/8/2019

ImpressCMS 1.4.0 Alpha 2 is now available

The second alpha for ImpressCMS 1.4.0, with fixes and improvements for PHP7, is out.

This second alpha improves PHP7 compatibility and updates libraries where necessary to be compatible with PHP7. Also, a bug that prevented the update of the version when running the update routine was resolved.

 

get it here on Github

Improvements

  • Update of Smarty to 2.6.31 (the latest 2.x release)
  • Update of CSS-tidy to work in PHP7
  • PHPMailer update to 5.2.7
  • PHPOpenID updated for better PHP7 compatibility

Bugfixes

  • succesful upgrade does now update the version number
  • code fixes to improve PHP7 compatibility

Known issue:

  • Protector is not yet working under PHP 7
  • Better handling of the protector preload is needed

 

Next version

The next version will be released once the protector module is running smoothly under PHP7. The core modules will also be tested for their PHP7-compatibility, and where needed improvements will be made.

The next version will be 1.4.0 beta.

The comments are owned by the poster. We aren't responsible for their content.