Fork me on GitHub
 

Module Compatibility with Xoops

Until version 1.2.x included, ImpressCMS is compatible with XOOPS modules that are compatible with Xoops 2.0.x. Starting with Xoops version 2.2, functionality was introduced and changed which made modules no longer directly compatible with ImpressCMS.

ImpressCMS-specific modules

ImpressCMS 1.2.x

Starting with ImpressCMS 1.2.0, new features were introduced in the ImpressCMS core classes. Several active modules have been using those new features. Depending on the version number of the module, it could be that at least ImpressCMS 1.2.x is required in order for it to run.

ImpressCMS 1.3

The 1.3 branch of ImpressCMS represents a major rearranging of the core. We took the opportunity to make the code structure, organisation and philosophy more compliant with current PHP best practices. This resulted in cleaner code, but also in a total reshuffle of the source. Every effort was made to ensure compatibility with ImpressCMS 1.2.

If the module you're trying to use doesn't follow the standard way of working of ImpressCMS 1.2, some minor edits might be possible.

Module Support

If an incompatibility should arrise, please let us know on the Modules Support Forum and we will be glad to analyze the problem and find a fix where it is possible.

We have worked hard and the ImpressCMS Addons web site is now open.

Last modified on 2011/5/12 by Anonymous
Comments
The comments are owned by the poster. We aren't responsible for their content.